Вышел обновлённый стабильный вариант Vivaldi 1.4 только для Linux. В обновлении (1.4.569.41) есть небольшое изменение работы браузера Vivaldi с флэш-плагином Adobe Pepper (PPAPI).

Попробовать обновленный Vivaldi 1.4 можно загрузив установочные пакеты с официального сайта Vivaldi.

Как работает новый плагин? Браузер Vivaldi при установке проверяет местонахождение плагина из официального пакета, предоставляемого партнёрами Canonical для Ubuntu Linux. Дополнительно, если у вас есть установленный Chrome в вашей операционной системе, Vivaldi может использовать плагин, поставляемый вместе с этим браузером. Если обе версии плагина доступны — Vivaldi определит самый новый из них и будет использовать его.

Ubuntu Linux

 

Если вы используете Ubuntu, вы можете использовать в терминале следующие команды для подключения репозиториев партнёров Canonical и установки из них официального флэш-плагина Adobe:

 

 

sudo add-apt-repository "deb http://archive.canonical.com/ubuntu `sed -n '/UBUNTU_CODENAME/s/.*=//p' /etc/os-release` partner"

sudo apt update

sudo apt install adobe-flashplugin


После перезагрузки Vivaldi (если он работал в момент обновления) вы должны получить работающую копию флэш-плагина в браузере.

 

Другие дистрибутивы Linux

Следуйте документации вашего дистрибутива для установки пакета, предоставляющего официальный Pepper/PPAPI Flash от Adobe. Если после установки такого плагина вы по-прежнему не видите его в браузере Vivaldi, сообщите в комментариях под этой статьёй название и версию вашего дистрибутива, а также путь, где разместился после установки флэш-плагин (если вы это знаете).

Также вы можете попробовать использовать данный скрипт, если в вашем дистрибутиве нет пакета Pepper Flash от Adobe.


Напоминаем вам, что еженедельные сборки являются тестовыми, поэтому не забывайте делать резервные копии важных данных. Сообщать о найденных ошибках можно по прежнему адресу.